Resolved
All impacted services have recovered.
Investigating
Our monitors have detected an increase in processing times. We are currently investigating.