extend

High API Latency
Resolved·Degraded performance
Sat, Nov 29, 2025, 08:18 PM
(1 week ago)
·
Affected components
APIs
Updates

Resolved

All impacted services have recovered.

Sat, Nov 29, 2025, 08:18 PM

Investigating

Our monitors have detected an increase in processing times. We are currently investigating.

Sat, Nov 29, 2025, 08:14 PM
Powered by