Resolved
The issue is resolved and everything was back up as of 10:55pm PST
Monitoring
Things appear to be back up and processing, but we are monitoring to make sure there are no remaining issues/backlog.
Identified
Our DB is under excessive load and jobs are not processing as a result. We have identified the issue and are working on getting things back up.