Resolved
This issue has been resolved and traffic returned to normal starting 4:10pm EST
Monitoring
Issue mitigated, and traffic has recovered. We're continuing to monitor to ensure things process smoothly.
Identified
We've identified the issue, and a fix is in progress. We expect to be back up shortly.
Investigating
Our database is under strain from excessive requests. We are working on a resolution