Resolved
All traffic has resumed normal processing times since 2:20 EST. Some orgs might have a backlog that is being worked through according to their limits.
Monitoring
System are recovered, we are monitoring traffic to ensure steady processing
Identified
We're rolling a few system components and should be processing at normal speeds soon
Identified
We have identifier an issue causing database strain and are working on resolving it
Investigating
We're experience elevated API latency and job processing for parsing and extraction. We're investigating